Temporary Email Delivery Disruption
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Dec 29, 2024 - 13:58 UTC
Investigating
We are currently experiencing a temporary issue with our email delivery service. Our team is working diligently to resolve this as quickly as possible. If you do not receive your code via email, please contact our support team.

We sincerely apologize for any inconvenience this may cause and appreciate your patience.
Posted Dec 28, 2024 - 18:18 UTC
This incident affected: Account Service.