Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 19, 2025 - 04:00 UTC
Scheduled
The OASIS regulatory service for GGPoker Germany will undergo scheduled maintenance. Players in Germany may experience issues with new logins and new account registrations. Players who are already logged in will not be affected.
Posted Aug 18, 2025 - 08:01 UTC
This scheduled maintenance affected: GGPoker (Login Service, Account Service).