Network connection issue in some regions
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Nov 26, 2023 - 16:39 UTC
Identified
Network connection issue has occurred in some regions of Europe area. When attempting to login in this area(s), players may experience network latency.
Posted Nov 26, 2023 - 16:13 UTC
This incident affected: Login Service.