Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 27, 2024 - 05:00 UTC
Scheduled
We will be performing software updates for regulatory compliance on Friday for GGPoker.nl accounts only. During this time, sign-up, log-in, and cashier functions will be restricted. - Sign-up and Cashier Services: Restricted from 06:30 to 10:00 CET. - Login: Restricted from 07:00 to 10:00 CET.
Posted Sep 26, 2024 - 15:36 UTC
This scheduled maintenance affected: Login Service, Account Service, and Payment.