issue on downloading installers for PC version
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 11:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 29, 2024 - 10:56 UTC
Investigating
There's an iusse that the players may be currently experiencing issues with downloading the PC version of our game client. We are working to resolve this and will restore service as soon as possible.
Posted Mar 29, 2024 - 10:02 UTC
This incident affected: Download (Download (Asia Pacific), Download (North America), Download (Europe), Download (Latin America)).