Delay in Spin & Gold service due to a surge in traffic simutaneously
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Jan 06, 2024 - 19:12 UTC
Monitoring
traffic on equal to or under $1 buy-in is getting relieved at this moment.
Posted Jan 06, 2024 - 15:43 UTC
Identified
A large number of players attempted to register for under $1 buy-in of Spin & Gold simultaneously, exceeding the limit at this moment. Please try again a few minutes later, maybe in 5 to 10 minutes.
Posted Jan 06, 2024 - 13:05 UTC
This incident affected: Spin & Gold.