[GGVegas] Minor Sign Up Issue Found

Incident Report for GGNetwork

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 11:47 UTC

Identified

We're currently experiencing some intermittent timeouts with our sign-up process.
We've identified the problem and are actively working on a fix.
Posted Jul 18, 2025 - 10:47 UTC
This incident affected: GGVegas (Account Service).