Temporary instability in Rush & Cash service.

Incident Report for GGNetwork

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 12:37 UTC

Investigating

Intermittent network issues have been detected on several Rush & Cash tables. We are working to resolve the issue and restore normal service as quickly as possible.
Affected Services: some of Rush & Cash game tables
Estimated Resolution: Within 10 minutes
Posted Aug 18, 2026 - 12:29 UTC
This incident affected: GGPoker (Rush & Cash).