a slight delay in giving Christmas Giftbox tickets and registering Spin & Gold due to too many request on the service
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 09:40 UTC
Identified
There may be a delay for some of the players to get the tickets and register the Spin & Gold temporarily.
Posted Dec 19, 2023 - 09:01 UTC
This incident affected: Promotion and Spin & Gold.